欢迎您,请 登录 或 注册会员

偶久网

搜索
偶久网 首页 工具补丁 查看内容

YDWE1.32.1测试版【制图必备软件】

2018-3-4 11:21| 查看: 1106 |原作者: 邪恶叔

YDWE有以下几个优点:
    1.兼容魔兽1.20和1.24
    2.自带官方免CD WE,稳定可靠
    3.兼容XP、Vista、Win7、Win8、Win10
    4.丰富的插件
    5.大量JASS系统和技能演示
    6.支持双开

使用方法:
    1.YDWE文件夹可以放硬盘任何位置,但需要注册表里有魔兽争霸路径;如果您无法启动YDWE,请使用注册表修复软件修复魔兽路径;
    2.编辑器会根据当前魔兽版本自动生成一个游戏缓存或Hash表,并且在保存地图和测试地图时,自动注入相应代码;
    注:如果选择保存为双份,那么原图始终是适合于当前魔兽版本的。而另一个带后缀的图是适合于另一个魔兽版本的;
    3.example文件夹下有测试地图,如果您不知道怎么设置参数,可以打开测试地图查看;
    4.打开配置文件YDWEConfig,可以设置地图保存选项;
    5.如果编辑器无法正常启动或出现BUG,请将logs\ydwe.log上传论坛(www.ydwe.net),以供我们研究;
    6.当地图保存时遇到问题,可以去论坛(www.ydwe.net)求助,或将地图发邮箱([email protected])。

YDWEv1.32.1测试版更新说明:

[New]Lua引擎支持指定调试器的端口号
[Fix]修正颜色插件无法加载的问题
[Fix]修正DX9无法加载的问题
[Fix]修正某些情况下无法正常启动的问题

1.20与1.24的互通
1.13版的YDWE已经可以在1.24下运行了——这大概是国内第一个可以在1.24下运行的WE插件;使用1.24魔兽版本的朋友不妨尝试下YDWE的新功能,但是,YDWE的功能不仅仅是兼容1.20和1.24,它还能实现地图的互通。我们知道,1.24禁了Return bug,而1.20下不能运行Hash表;为了解决这个纠结的问题,YDWE提供了一套存储函数;在1.20下将数据用Return bug存到GC,在1.24下存到Hash表。
现最新版本为YDWE1.29.4正式版
YDWEv1.29.4正式版更新如下:[2]
增加了几个新的注释
修正地形突破器失效的问题
YDWEv1.28.7正式版更新如下:[2]
修正 D3D9 渲染引擎没有生效的问题
修正配置需要重启 ydwe 才生效的问题
修正读取 UI 文件时没有忽略 utf8 bom 的问题
修正地形突破器没有生效的问题
成功兼容的UI
YDWE可以兼容老狼UI、wow8UI和夜天UI
附录——YDWE-功能手册
YDWE包括以下部分:
- YDWE核心(Aeris)
- YDWE函数库、UI库和美工(Everguo, Walatoo,Warft_TigerCN,Fetrix_sai,C kuhn)
- Horus(0.4.6.T)(ADOLF, Van Damm。基于TESH)
- PJass(1.0j)(Jeff Pang以及其他贡献者,Aeris修改,修正了内存溢出的问题)
- JassHelper(0.A.2.B)(Vexorian)
- AdicHelper(1.4.2.12)(ADOLF, Van Damm)


下载地址:https://pan.lanzou.com/i0l807g